Delay in Email Delivery
Incident Report for Skeddly
Resolved
The email delays have been resolved.
Posted over 2 years ago. Aug 31, 2016 - 21:07 EDT
Identified
The third-party service that Skeddly uses for email delivery is experiencing delays sending emails. Emails including action completions, reports, account and email verifications are currently experiencing delays.
Posted over 2 years ago. Aug 31, 2016 - 12:00 EDT