Emails & Notifications Impacted

Incident Report for Skeddly

Resolved

Notifications appear to be flowing nicely now.
Posted Oct 20, 2025 - 17:03 EDT

Monitoring

AWS has allowed us to launch our Notification service. So that's happened now and notifications are flowing again.

We are monitoring the situation for issues.
Posted Oct 20, 2025 - 15:43 EDT

Update

In an effort to resolve their own issues, AWS has rate limited customers. This rate limit is preventing us from launching a fresh Notifier service.

So we continue to wait.
Posted Oct 20, 2025 - 12:51 EDT

Identified

Due to the ongoing AWS outage, emails and other notifications are impacted.
Posted Oct 20, 2025 - 09:35 EDT
This incident affected: Notification Infrastructure.